Sync – An SQL data change is not permitted for a read-only connection, user or database.

  • 21 June 2024
  • 0 replies
  • 12 views

Userlevel 1
Badge

This error can indicate one of the following: 

  • The disk that Sync is trying to store data on is full 

  • Sync does not have permissions to write to the Derby database or SQLite database that it uses to store Sync information 

 

Solutions to try 

If your disk is filling unusually fast, this can indicate that ‘Verbose’ level logging may have been left on one of your jobs as well as the retention period of your logs being too long. 

To disable verbose logging on your job, go to Jobs -> Click into the relevant job -> Overview -> Edit Logfile verbosity in your overview settings to ‘Info’. 

To fix your log retention issues, go to Settings -> Advanced and modify the Retention Period setting. You can also manually run a clean-up to delete any excess files. 

 

 

To check for permissions on your Derby DB or SQLite databases if Sync is being run as a service, check if ‘NETWORK SERVICE’ has access to the path being used by right clicking the folder->Properties, the default path on Windows is C:\ProgramData\CData: 

 


 
If you have confirmed all of the above, you can also try restarting Sync as the Derby DB may not have started up correctly. 

 

As a last resort, you can try deleting the db.lck file located(in Windows) in the following path: 

C:\ProgramData\CData\sync\db\cdata_sync 
 
Please reach out to support@cdata.com if this does not resolve the problem for you.  


This topic has been closed for comments