Solved

Error adding task to job

  • 23 November 2023
  • 2 replies
  • 40 views

Badge

I’m attempting to add a task to an existing job and get an error:

“The job <job-name> contains an unlicensed connection: Only 10 tasks are allowed in the Job”

 

I also tried creating a job from this existing job and got an error:

The connection [Salesforce_abc] is unlicensed: Unlicensed connections cannot be shared across multiple jobs.

 

We have an Enterprise license, and my job is using SalesForce as a source and Azure SQL as a destination. 

I tried adding a task to a different job that uses Salesforce as source and Azure SQL as destination, and it worked.

icon

Best answer by Ankit Singh 27 November 2023, 15:05

View original

2 replies

Userlevel 5
Badge +1

Hi @Rajesh 

Since this requires a bit of investigation, it’d be best to raise this as a Technical Support case with our teams at https://www.cdata.com/support/submit.aspx.

We have seen some fairly similar problems in the past that were shown in more detail in logging when Sync starts via the App logs. We’d like to check those first to determine if it's the same behavior as before, or if this is something new. On your Settings page, within Sync, can you go to the Advanced tab and change the application log level to All, then restart Sync?

This should help us identify any concerns in the startup licensing check. You can download those logs via the Logging page in Sync under the Application Logs tab and send those along with the details to our Tech support team.

Badge

Thanks Ankit. For now, we got around this by creating a new connection with similar details. We haven’t experienced an issue since.

Reply