Solved

Exception happened: Failed to start database

  • 12 March 2024
  • 2 replies
  • 40 views

Userlevel 1
Badge

Exception happened:
Failed to start database 'C:\ProgramData\CData\sync\db\cdata_sync' with class loader WebAppClassLoader{CData Sync}@20ce78ec, see the next exception for details.
ServletPath: /login.rst ContextPath:

 

 

icon

Best answer by Ethem Q 12 March 2024, 17:03

View original

2 replies

Userlevel 5
Badge

Hi @CharleyG 

The short answer is that we have seen other users report the same error message typically when an attempt to start Sync fails due to another process holding on the Sync database. A very common scenario that would cause this issue is for example when an attempt to restart sync is made while a job is in the process of being cancelled. The easiest solution to bypass the error is to simply restart the machine where Sync is installed on.

 

However, we have also had several users update to the latest version of Sync as our team has recently worked on a fix to better handle this particular error. You might want to download and update to the latest version: https://www.cdata.com/sync/builds/ 

 

Feel free to reach out to our support team at support@cdata.com if you encounter any other issues.

Userlevel 1
Badge

Thank you @Ethem Q  It worked. As a beginner to CData, I was worried about this issue

Reply