Solved

Issue with CDATA Sync Job Using Incremental Replication Despite Removal

  • 27 November 2023
  • 3 replies
  • 85 views

Badge

Hello CDATA Community,

I hope this message finds you well. I am currently facing an issue with the CDATA Sync tool and would appreciate any insights or assistance from the community.

Problem Description: I have configured a job with a single task, where the source is Salesforce, and the destination is an SQL database. Initially, I ran the task without incremental replication, and it successfully synchronized all records for a specific Salesforce object. Later, I implemented incremental replication and verified that it worked as expected. However, when I decided to remove incremental replication and attempted to sync the data again, the job seems to persist in using incremental replication, and not all data is being synchronized.

 

Steps Performed:

  1. Created a job with Salesforce as the source and SQL database as the destination.
  2. Ran the task without incremental replication, successfully syncing all records.
  3. Implemented incremental replication and verified its functionality.
  4. Removed incremental replication from the configuration.
  5. Attempted to sync data again, but the job appears to still use incremental replication, not syncing all records.

Expected Outcome: I expected that after removing incremental replication, the job would revert to syncing all records rather than just the incrementally changed ones.


Request for Assistance: I am seeking guidance from the community on how to troubleshoot and resolve this issue. Is there a step I might be missing or a configuration that needs adjustment? Any help or insights would be highly appreciated.

icon

Best answer by Ankit Singh 27 November 2023, 08:05

View original

3 replies

Userlevel 5
Badge +1

Hey @Satyendra 

Thanks for being so detailed with your description of your problem! However, the answer is actually very simple. By default, all the jobs configured will use Incremental replication to replicate your data from source to destination. In this case, Salesforce to SQL Server.

If you want to disable incremental replication, or force a full load from source to destination, enable this property in the Advanced configuration of your job:

Drop Table = True;

When enabled, the application will drop the table in the destination first and then replicate the data from source, which forces the application to do a full load.
 

Let me know if this helps!

Userlevel 3
Badge +1

It does seem like there are at least some settings at the job level which get “stamped” on the individual tasks at their creation, and if you later change job-level settings, the tasks do not re-inherit those changes.  I’ve found I often need to edit the job-level information, delete the existing tasks, and add them back.

Userlevel 5
Badge +1

@DougN Nouria Ideally, that shouldn’t happen. If that is the behavior you see, it is best to report it as a bug to our Tech support team.

Reply