Solved

Quickbooks to Sql Server Replication Error


Userlevel 2
Badge

Hi all,

I am receiving an error when I am trying to replicate a table from QuickBooks to a local SQL Server.

“[0] Failed to cache row [126934] The iteratorID "{4853b873-e75a-4f1a-a4d6-2c32253237ad}" is not valid.”

See the screenshot below. To try and address this I have: 

  1. Decreased the Pagesize property in my Quickbooks connection to 50 from 500.
  2. Enabled Persistent connections and increased the idle timeout in my Quickbooks Remote Connector from 30 to 120.

I restarted the services but none of that worked. Any suggestions?

 

 

icon

Best answer by Ankit Singh 27 May 2024, 10:22

View original

10 replies

Userlevel 3
Badge +1

Is this a local Quickbooks database/file, or is it Quickbooks Online?

The fact that it ran for 22 minutes before failing would seem to suggest that it was partially complete before failing.  Do any rows at all get loaded?

If it’s Quickbooks Online, does QB give you any control over (or describe) the timeout period on their end?

Userlevel 2
Badge

Hi DougN, thank you for the quick response. It is the QuickBooks desktop. The QB, SQL Server, and CData Sync are all on the same virtual machine. The table is empty after the error. I am rerunning it once again with verbose messaging to see if I can provide a better idea of what is going on.

Userlevel 3
Badge +1

Will it load any other tables from the QB file successfully?

Be sure nobody has the file open in QB…

 

Userlevel 2
Badge

Yes, one of the tables was successfully loaded. The Accounts table with 479 rows was loaded, then the next 3 with 80k to 200k rows failed with the same iteratorID error for each table.

 

Userlevel 2
Badge

As you can see replication attempt managed to create the tables in SQL Server, but other than Accounts, the others are empty.

The file is not opened by anyone else.

Userlevel 2
Badge

I made one more change when I turned on verbose. It allowed me to turn on parallel processing with 2 worker pool. So far it has not errored out. Still going… I hope I haven’t jinxed myself. I’ll update with results: 

 

 

Userlevel 2
Badge

Hmm it shows as 0 rows affected. We shall see: 

 

Userlevel 2
Badge

😔

 

 

Userlevel 5
Badge +1

Hey @SalD 

This will require some investigation. Why don’t you raise a Tech Support Case with our support team along with verbose logs and screenshots at CData - Support Form?

From the prima facie, maybe reducing the Page Size on your QuickBooks connection will help.

Userlevel 2
Badge

Hi Ankit, I did reduce the page size, that was the first troubleshooting step I took. It is in my first post above. Should I reduce it lower than 50?

 

I have submitted a support ticket and am waiting for support to respond. Thanks.

Reply