Solved

Task data source settings grayed out in the Sync version 23.4.8843.0

  • 5 April 2024
  • 3 replies
  • 66 views

Userlevel 1
Badge

I’ve updated our test environment to latest version 23.4.8843.0 and I noticed that when I try to configure data source settings, I can’t and I get information “Settings are not editable”. Same issue with new tasks and previously created tasks. I can however make settings directly to query-tab and it will work ok. Our production environment is version 23.3.8700.0 and that issue is not there. Data source which I’m using is ElasticSearch

icon

Best answer by Ethem Q 10 April 2024, 00:56

View original

3 replies

Userlevel 5
Badge

HI @JTapio 

Typically you would be getting a message indicating that ‘Settings are not editable’ for most tables when we have already predefined the Incremental Check Columns of these tables to apply the Incremental Replication logic. 

However, with some of our sources, including Elasticsearch, for most of the tables in the Tasks that you have created it is unlikely for them to support a default IncrementalCheckColumn due to the nature of Elasticsearch as a source. One way to resolve that is by defining an IncrementalCheckColumn by following the steps here:

https://www.cdata.com/kb/entries/sync-incremental-config.rst 

 

In case the task’s settings still appear as not editable or that column is not listed in the UI, you can change it by writing a custom query as in the following syntax:

REPLICATE [TABLENAME] WITH IncrementalCheckColumns = 'SomeDateColumn' SELECT * FROM [TABLENAME] WHERE ... 

 

If the above suggestion does not resolve your issue, kindly submit a support ticket here and make sure to provide screenshots and other relevant details about the issue so that our support team can further assist you.

Userlevel 1
Badge

We have been using ElasticSearch data source already couple of years and incremental replication has worked fine. Like I wrote I can get it working by writing “WITH IncrementalCheckColums” directly to the query, but something has changed in the new version, because I cannot do it any more using GUI

Userlevel 5
Badge

Hi @JTapio 

I am not sure what exactly has changed but it would be helpful if you could provide a screenshot of the previous working configuration. In the meantime, another possible workaround is to add the ‘IncrementalCheckColumn=DateField’ in the AdditionalOperations in the Advanced tab in the Task as in the following example:

Also, I would suggest you reach out at support@cdata.com and submit a support ticket here with the details of the issue and the relevant screenshots so that one of our support agents from the Sync team can further assist you.

Reply