Solved

Missing item field in Netsuite connector

  • 5 January 2024
  • 3 replies
  • 64 views

Userlevel 2
Badge

Hi Folks,

Good to be part of this group. I recently started using Cdata to load reports from Netsuite for one of my clients. As we load the Sales Oreder table using SuiteTalk, we find that the item column is not available in the preview. What could be the reason for this? We are at an impasse right now as it’s imperative we get the item field. 

Initially we thought it was an access issue with the Cdata user, but we have ensured that our user has all the necessary permissions to load this data. 

icon

Best answer by Ethem Q 6 January 2024, 00:09

View original

3 replies

Userlevel 5
Badge

Hello and welcome to the community!

It's great to hear you're using CData for your Netsuite reporting needs. Your issue with the missing 'item' field in the Sales Order table sounds perplexing, especially since you've already checked the user permissions. Here are a few steps you can take to troubleshoot this:

  1. Check Field Settings in Netsuite: Sometimes, specific fields may not be enabled or visible by default. Ensure that the 'item' field is set to be accessible through SuiteTalk in your Netsuite settings.

  2. Review CData Connector Configuration: Verify if there are any specific settings or filters applied within the CData connector that might be excluding the 'item' field.

  3. Schema Refresh: If the schema in CData hasn't been refreshed recently, it might not be reflecting recent changes made in Netsuite. Try refreshing the schema in your CData connector.

  4. Netsuite API Version: Ensure that the version of SuiteTalk API you are using is compatible with the version of Netsuite your client is using. Incompatibilities here can sometimes lead to missing fields.

  5. Check for Customizations: If the Sales Order table or the 'item' field is customized in your client's Netsuite setup, it might affect its visibility through SuiteTalk.

  6. Contact Support: If none of the above steps work, I recommend reaching out to CData's support team for further assistance. They might have specific insights or updates that could resolve your issue.

If anyone else in the community has faced a similar issue or has additional insights, feel free to chime in. Collaboration often leads to the best solutions in our field!

Keep us posted on your progress, and let's work together to solve this.

Userlevel 4
Badge

It is important to first check the permissions and confirm that your user has the right permissions to access Items.  In NetSuite, there are many permissions that may be used by the driver.  Permissions may be configured for a role in NetSuite under Setup --> Users/Roles --> Manage Roles. You can read more about the permissions our driver might require at the following link: http://cdn.cdata.com/help/DNJ/odbc/pg_permissions.htm 
 

If the permissions are in place then you might want to check a couple of things on the driver's side:

 

  • NetSuite’s API does indeed expose Item for SalesOrder Object. However, since SuiteTalk’s database is massive, for optimization purposes, we have limited some tables/columns which can be shown visually. If you want to get all the columns including the ItemListAggregate you will need to set the AggregateColumnMode to ListAndRetrieve. Please note that this will impact the performance for loading times. Read more  here:https://cdn.cdata.com/help/DNJ/odbc/RSBNetSuite_p_AggregateColumnMode.htm 

 

  • Retrieve the Items from the SalesOrder_ItemList. If you are not seeing this table then you need to set a property called IncludeChildTables in the connection configuration. Setting this value to True will display a table called SalesOrder_ItemList which exposes the list of SalesOrder Items, along with all child tables in the database. Read more here: https://cdn.cdata.com/help/DNJ/odbc/RSBNetSuite_p_IncludeChildTables.htm 

 

I assume that to access the ‘SalesOrder_itemList’ table, you will have to go to the Permissions>Transactions section and add the ‘SalesOrder’ permission. You might also need to go to the Pemissions>Lists section and add the ‘Items’ permission. 

 

Let us know if that helps.

Userlevel 2
Badge

Hi Ethem, We followed the steps mentioned in your reply and we are getting the item info. We are getting it in a cluttered fashion but we are successfully extracting it using Regex. Thank you for the support. Looking forward to contribute and engage to the community going foraward!

Reply