I tried to use the embedded Xero credentials, but get a message about hitting a connection limit.

  • 19 April 2023
  • 1 reply

Userlevel 1

I was using the one of the CData Xero drivers, and followed the instructions to set up the connection using the credentials embedded in the driver, however, when I tried to verify the connection the following error occured:


How should I change the connection to fix this?


Best answer by Zachary G 19 April 2023, 17:59

View original

1 reply

Userlevel 1

Currently, the credentials embedded and used by default in the Xero drivers have hit a limit imposed by Xero. The CData team is working with Xero to increase this limit, but as that is a slow process, setting up your own OAuth credentials is an easy way to bypass the issue altogether. 

To set up these credentials, use the below tutorial to set up your own OAuth Desktop Application or Custom Connection Application.

After setting up a custom OAuth application, the below tutorial goes over setting the needed driver properties to use the new connection.


Combining these tutorials will bypass the connection limit error, and allow use of the driver to its full extent.